Forums

ForumsSupport Forum

MMOs on AG

Posted Nov 16, '12 at 8:17pm

EagleOfFire2

EagleOfFire2

131 posts

Now, I really dislike MMOs. It is really the kind of game I think should not happen at all for a flash game. Doesn't make sense in any ways and there is already so many of this kind of games flooding sites like Facebook and whatever... But even then, there is still sometimes gems in genres I loathe which make them worthwhile to play. And of course you can't know that without trying them.

So that new Pirate MMO look interesting to me. That's a theme (space exploration and combat etc) which I like. So I thought, I guess I'll give it a try to see if it's any good.

Now, here's the problem: please explain to me how I'm supposed to stop thinking that MMOs are crap if they don't even start or launch if I want to try them?

When I click on the icon to start the game, I'm brought back to the exact same page I was before.

 

Posted Nov 16, '12 at 8:42pm

SwordmasterQ

SwordmasterQ

23 posts

Funny, when I try to play it I get a website restore error. this also happens with dino storm.
maybe the creators of these games should look in to MAKING THEM PLAYABLE!

 

Posted Nov 16, '12 at 9:04pm

xXxDAPRO89xXx

xXxDAPRO89xXx

4,300 posts

.

Funny, when I try to play it I get a website restore error. this also happens with dino storm.
maybe the creators of these games should look in to MAKING THEM PLAYABLE!

lol... It's not the creators... Its just a glitch you encounter when you play MMOs on AG. Been happening for a while... But not to me though lol :P

 

Posted Nov 16, '12 at 9:20pm

daleks

daleks

3,296 posts

It works fine for me. According to the Pirate game you are talking about you need to have Java. Maybe you just haven't downloaded it yet? If that doesn't work check to see if your browser is up to date or just try a different browser.

 

Posted Nov 16, '12 at 9:56pm

EagleOfFire2

EagleOfFire2

131 posts

In short: we don't want to help you?

 

Posted Nov 16, '12 at 11:10pm

daleks

daleks

3,296 posts

In short: we don't want to help you?

I thought that my ideas were helpful. Did you try all of them and did it still not work?

 

Posted Nov 17, '12 at 12:18am

EagleOfFire2

EagleOfFire2

131 posts

Java is required to log in to this site.

Saying I need another browser is like a slap on the face.

My browser is just as up to date as it will ever be able to be even though it's not supported anymore.

And, more to the point: it doesn't help much with the fact that the site send me back to the very same link I was at when I clicked on the "play now" button!

 

Posted Nov 17, '12 at 3:48am

MrDayCee

MrDayCee

8,732 posts

Moderator

Easy there EagleOfFire2... other users are only trying to help you, something they are not required to, but want to do out of their kindness and willingness. ;)

The problem you're having seems to be one where the page HTML is flawd and redirects you to the same page again, something that can happen. I will notify an admin about it and he can have a look and maybe easily solve the problem for you, ok? =)

 

Posted Nov 17, '12 at 5:02am

EagleOfFire2

EagleOfFire2

131 posts

Thank you for the reply MrDayCee. At last some useful help.

Not that I don't like people who try to help... But I do prefer people who know what they are talking about.

FYI, to try to pinpoint the problem more easily, I just tried to load other random MMOs and clicked on the play button. None worked for me so the problem seem to be general to all of them.

 

Posted Nov 18, '12 at 8:15pm

EagleOfFire2

EagleOfFire2

131 posts

I hate to be back at it but the problem still persist.

 
Reply to MMOs on AG

You must be logged in to post a reply!