ForumsSupport Forum[Necro] Problems playing games on 12/27? - POST HERE!

121 10553
DAH92
offline
DAH92
1 posts
Peasant

Impossible to play MMO. Blank page or error message server. please help me.

  • 121 Replies
Ferret
offline
Ferret
9,293 posts
Constable

Could you try another browser or clearing your cache. Let me know at Ferret@Armorgames.com if it's still broken, and we'll work together on fixing it.

gorangar
offline
gorangar
7 posts
Farmer

same here, there is another thread regarding this problem in the MMO-forum but I think support is the appropriate one.

SeaPiper
offline
SeaPiper
4 posts
Blacksmith

Tried three browsers. MMO games are down, or rather the ones I want to play are down. Didn't try them all.

ValDon
offline
ValDon
3 posts
Peasant

My wife myself and my best friend are all having the same problem. The game we are logged in on are working fine but any we try to pull up now are not working

Rilien
offline
Rilien
4 posts
Peasant

5th Planet MMOs are still down. Tried three browsers (Firefox, Chrome, Safari), refreshed cache in each and tried again, and it's still broken.

boppins
offline
boppins
724 posts
Herald

Please try again, I just updated the cache for the users in this thread. Post again if it's still not working.

heavenlydreamer
offline
heavenlydreamer
1 posts
Peasant

i'm also having problems logging into mmo games. legacy of a thousand suns being the main one i'm trying to play.

gorangar
offline
gorangar
7 posts
Farmer

Sadly its still not working. I cleared my browser cache, updated my AG-profile, tried Firefox as well as Chrome, nothing helps so far.

Rilien
offline
Rilien
4 posts
Peasant

It's also still not working for me, unfortunately.

ValDon
offline
ValDon
3 posts
Peasant

still not working, tried with firefox and internet explorer

przem0l
offline
przem0l
7 posts
Shepherd

Ok, mmo games dont work for everyone. So maybe little fix? WE PAY FOR IT guys. I know that we have xmas... but there are events right now and we wasted a lot of cash to get better rewards..

myiai
offline
myiai
7 posts
Peasant

not working getting blank page with evry mmo ...

bowhunter
offline
bowhunter
5 posts
Bard

I have tried multiple times clearing out the cache, but no luck in logging into any mmo games.

gorangar
offline
gorangar
7 posts
Farmer

I AM IN, it is working for me now!

Solution: I had to reset my router to get a new IP, now it works fine. Maybe this helps for you guys as well.

GrappleX
offline
GrappleX
11 posts
Jester

It's working for me, and I didn't have to reset my router or anything. I guess it's not a site-wide thing.

Showing 1-15 of 121