ForumsSupport ForumArmor Mayhem Chronicles

5 1411
Rayce002
offline
Rayce002
137 posts
5,275

I've been having a very hard time with the maps loading with this game. They take anywhere from 2-5 minutes and that's not including the lag in-game.

I have very high-speed internet, running firefox, and have an up-to-date computer including hardware.

Help!

  • 5 Replies
Rayce002
offline
Rayce002
137 posts
5,275

Note: still having the issue after clearing my cache, as well as having this issue on Chrome and IE.

Rayce002
offline
Rayce002
137 posts
5,275

Anyone have any idea how to try and fix this? Mods? Admins? Someone?

Thanks in advance,
-Rayce

xXxDAPRO89xXx
offline
xXxDAPRO89xXx
6,795 posts
17,055

Hmm... How much crap do you have on in the back? If you are running tons of stuff it will lag your computer. (take it from me. I do it all the time xD)
If you don't have anything running than try using a different browser. (you should use chrome)
That's all I know...

MrDayCee
offline
MrDayCee
13,320 posts
30,235

Armor Mayhem is one of the heavily played games on this website, which causes the game to lag a lot during a peak moment of gamers. If the problem keeps persisting, I can only suggest the same thing Dapro did... Try to run as few programs as possible when playing this game and do not open any extra tabs in your browser to make sure.

If the problem is not resolved in a few days, let us know in this thread and I'll forward it to an admin, unless Ferret checks in here before that, ok? =)

Rayce002
offline
Rayce002
137 posts
5,275

Not running anything in the back, and the problem unfortunately spans Firefox, Chrome, and IE.

I got it to run this morning, and the only thing that lagged was the "Drawing Map" portion. In-game lag was nearly gone.

Thanks for the suggestions guys. I'll keep trying and keep you posted

Showing 1-5 of 5