ForumsSupport Forum[Answered] Connecting to armor games issue

7 3733
kamikazied
offline
kamikazied
2 posts
610

Normally, when I go to play my MMO's, I got right through without the screen saying 'Connecting to armor games'. But recently I got my software update, and now they stop at this screen. Is there something 'wrong' with the new windows update, or is my computer just being a jerk? I've tried another computer, which had the same update, and it didn't work on that one either. And my connection is normally perfect when I try to connect, but this happens. I just want to know, so I can get back to my online games.

  • 7 Replies
kamikazied
offline
kamikazied
2 posts
610

Actually, after configuring a few things, it works on most games, but not Dead Zone for some reason, and that was one of my favorites....

sarnagon
offline
sarnagon
5 posts
2,635

Have you tried to us a another browser for example firefox and internet explorer.

Ferret
online
Ferret
9,209 posts
6,055

If you continue having this issue, please contact me with the details at Ferret@ArmorGames.com.

noppie
offline
noppie
1 posts
215

Connecting to Armor Games...

With:
Windows 7 64-bit
Opera 18.0.1284.68
Flashplayer 12.0.0

Cryptexas
online
Cryptexas
1 posts
160

same problem

The Last Stand Dead Zone only use the Connecting to Armor Games...

still load since 30min and nothing happes

rmeans6556
offline
rmeans6556
2 posts
185

dawn of dragons and last stand im gettin that **** error 500

MrBesonders
offline
MrBesonders
3 posts
3,285

Crusaders of the Lost Idols is the same.

Showing 1-7 of 7