Forums

ForumsSupport Forum

[Answered] Can't Play Any Games

Posted Jun 29, '13 at 8:50pm

Karasaar

Karasaar

165 posts

This happens with just about any game on AG for me, currently.
Ads before the game still play, but the game itself isn't launched.
[IMG]http://i.imgur.com/7jrnEvA.png[/IMG]

Browser: Firefox 22.0
Shockwave Flash: 11.7.700.224

 

Posted Jun 29, '13 at 8:51pm

Karasaar

Karasaar

165 posts

http://i.imgur.com/7jrnEvA.png
Whoops, image screwed up.

 

Posted Jun 29, '13 at 8:58pm

UnleashedUponMankind

UnleashedUponMankind

6,803 posts

Moderator

Did you try to refresh the page (maybe a cpl of times)?
Browser/flashplayer up to date?
Did you try it with another browser?

 

Posted Jun 29, '13 at 9:05pm

Karasaar

Karasaar

165 posts

I refreshed a lot of times and tried different games. Didn't try other browsers yet. I'll see if that works.

 

Posted Jun 29, '13 at 9:07pm

Karasaar

Karasaar

165 posts

Allright, it seems to work on Opera, still weird how it doesn't work on FF at all. Is anyone else expiriencing this?

Also, I have the newest versions, as you can see from what I've posted.

 

Posted Jun 30, '13 at 10:42am

AzureDragon

AzureDragon

6 posts

i have the same problem,i tried to uninstall and reinstall Firefox,java and flash player(and i deleted cookies too) non of them solved the issue.

 

Posted Jun 30, '13 at 11:47am

AzureDragon

AzureDragon

6 posts

btw its working with chrome and IE too

 

Posted Jun 30, '13 at 12:05pm

MacII

MacII

1,369 posts

I'm on Firefox and have no issues.

I reckon you may need to look at your plugins and see if that's all runing well. At my end (Firefox 21), that's under >Tools >Add-ons, now in the resulting window check both your extensions and plugins.

Also, check if you don't have an ad blocker or similar running that stops Flash Player from working, both for this site, and in the case of MMO (multiplayer) games the sites that they may actually be hosted on.

 

Posted Jun 30, '13 at 12:07pm

MacII

MacII

1,369 posts

Um, make that FF 22.0, now that the latest update got installed as I was checking the version nr. for the above

 

Posted Jul 1, '13 at 7:00pm

AzureDragon

AzureDragon

6 posts

Well i checked my add-ons too and all of them seems working pretty well, i can open games from other game sites,i can watch videos and gifs etc. just armor games is not working there is something really wrong over here (btw fyi, i can open Dawn Of the Dragons without any problems and i tried to open other games like "The Last Stand(this one got stucked at connecting armor games)" and "Swords and Potions" working well like Dawn Of the Dragons).

 
Reply to [Answered] Can't Play Any Games

You must be logged in to post a reply!