Forums

ForumsSupport Forum

[Answered] Uh...? (Time World Login)

Posted Sep 2, '13 at 12:06am

InvalidUser123

InvalidUser123

39 posts

I'm wondering if anyone else is experiencing this. I've been trying to play Time World for a couple months now. I've been trying to play from here, and also from Kong, but I can't.

The problem I am having is this: the game is not loading. It sits at character creation, the game says "loading" but it never does anything.

I'm certain it's not anything on my end, but nobody else seems to have this happen, and the developers aren't responding to me. Does anyone have any ideas?

 

Posted Sep 2, '13 at 12:44am

InvalidUser123

InvalidUser123

39 posts

Sorry, forgot to mention before: I know it's not a process thing, as I am not using a firewall when trying to load, and was tested on Firefox, Opera, and (God help me) Internet Exploder, all from 2 different computers, using 2 different connections.

I thought maybe it was my firewall at first, but there was no change after it was disabled. somebody mentioned that maybe it could be a port issue, but I really hope that isn't the case.

 

Posted Sep 2, '13 at 4:46am

MacII

MacII

1,369 posts

You're probably blocking something. I left my thoughts on these issues e.g. here, see what you make of it.

 

Posted Sep 3, '13 at 4:53am

MrDayCee

MrDayCee

8,775 posts

Moderator

Just to make sure, I checked and I was able to login fine for this game... everything went smoothly. All that I can ask you is to contact the game developers again and hope they have the time to respond to your problem. This can take some time as they are busy, but my experience is that they will respond, albeit a little late. ;)

 

Posted Sep 4, '13 at 6:12pm

MacII

MacII

1,369 posts

somebody mentioned that maybe it could be a port issue, but I really hope that isn't the case.

I wouldn't really expect so, either; however I guess some of these MMO's may require incoming connections, so open port(s) on your part. There was a case recently discussed here: http://armorgames.com/community/thread/ … ect-error/ .

Either way, you'd need the developers to tell you which ports, or hopefully the game instructions or documentation might tell you about it. It would then depend on your set-up whether this interferes for you; or in that discussion, it turned out people were running into their ISP's (internet service providers) blocking such traffic.

I think game developers should invest in thinking not just from their point of view, but rather from that of greatest user-friendliness to all, but, it's a little out of scope here (you'd think using common ports for this, if at all, would help). Indeed I doubt it's what you're looking at here, but then who knows.

 
Reply to [Answered] Uh...? (Time World Login)

You must be logged in to post a reply!