Forums

ForumsSupport Forum

[Closed] Problems with MMO

Thread Locked

Posted Oct 23, '13 at 9:33pm

HughMasters

HughMasters

3 posts

I been trying to conect to the last stand-deadzone...but it always says "connection error"

 

Posted Oct 23, '13 at 9:55pm

edAshWilliams

edAshWilliams

6 posts

same issue - Legacy of a Thousand Suns

 

Posted Oct 23, '13 at 10:00pm

erkper

erkper

2 posts

same problem, DotD

 

Posted Oct 23, '13 at 10:15pm

demacus

demacus

1 post

same issue  started a hr or 2  ago cleared flash cookies can't login to dotd or galaxy online now

 

Posted Oct 23, '13 at 10:23pm

BlackMatters

BlackMatters

1 post

Same issue, DotD, and i'm not even able to post a comment to Comment Section of the game. (Not the Chat, the comment on the lower part.) And the Chat isn't working too, which is strange. Even under maintenance, Chat works.

The Comment section says i'm not logged, even i'm being logged.

Just hope that this is fixed soon. :DD

 

Posted Oct 23, '13 at 10:34pm

jyou27

jyou27

3 posts

Me too LoTS and DotD down for me

 

Posted Oct 23, '13 at 10:44pm

bohagon

bohagon

1 post

Every MMO on Armor that I have tried cannot connect to server. In DotD usually if its traffic related the chat will still work, but the chat too is down.

 

Posted Oct 23, '13 at 10:48pm

frijolito_uk

frijolito_uk

2 posts

Me too, connect error displayed, some problem to do with Armor games authentication server, hope they are working on it...

 

Posted Oct 23, '13 at 11:04pm

nluecking

nluecking

2 posts

same problem here too

 

Posted Oct 23, '13 at 11:13pm

diggitydag

diggitydag

1 post

Agreed. Getting Armor Game Authentication Error but I can login/out and edit my profile.