ForumsNews, Feedback and Suggestions

About this downloadable Player needed to play some games..

Posted Dec 21, '13 at 5:00pm



1,369 posts


the Java Development Toolkit plugin

For the sake of reproducibility, and working on the assumption that this may somehow find its way to the Unity folks, I tried to reproduce the above after a system reboot, but failed to. That is to say, I didn't get prompted to allow no Java plugin. Don't ask me, something must have blocked something.

In Firefox, there are two Java plugins involved: A Java Platform plugin (currently SE7 U45, for Windows), and said Java Deployment Toolkit.

As said, the latter has been marked as vulnerable by Firefox for quite some time now; the former used to be for a while, but of late has apparently been found safe by them again, it comes with no notifications.

As said, plugins marked as vulnerable are switched to "ask to activate" by FF by default. The Deployment plugin I have set to never activate; the Platform plugin I still have set to "ask to activate," even though if their evaluation of it is right, that should no longer be necessary.

I can't be sure if in my above description, it was in fact the Deployment plugin that was prompted for, or rather the Platform one. Either way, allowing whatever was prompted once didn't do the trick; then setting the Deployment plugin to ask to activate, it did work.


Posted Jan 4, '14 at 6:44am



1,369 posts

Heyyy, sha-wow: fixed (to get Unity Player to work, in WinXP using Firefox, for those too lazy to read back to see what this was all about )

Thanks to this post in the Unity forums, that indeed did fix it:

So to turn on Windows' Terminal Services. I reckon like that poster, I must have turned it off myself at some point since it's mostly related to sharing one's machine with outsiders, something I have no intention of doing. Notes:

* Setting Terminal Services to manual startup seems to already auto-start them, so that setting suffices.

* In my set-up at least, it still requires me to, in my software firewall, allow incoming connections for the Plugin Container for Firefox to work (Mozilla Firefox\\plugin-container.exe).

(And I'm not too happy with either of these settings, so may well switch it all off again. But, hey, at least it looks to be weeding out the issue )

* About that Java plugins business I mentioned above, none of it seems to have any bearing on my test runs now, so whatever was called for there, it doesn't seem to apply here. May be conveniently disregarded, I guess.

The game I used for testing was Crazy Fairies again, seems to be fully functional then.

For those who wonder What services???, maybe this will help to explain: .

I'm on a non-English system, but to get there, on your Windows machine go through what must be called in English roughly >Settings (/Control Panel?) >System Management (? /Systems Manager?) >Services. Do note: These settings should not be tampered with if you don't have some idea of what you're doing. If anything, get acquaintd with it all a little before you do make any changes there; you could well be rendering your machine useless, or your internet access disfunctional, or whatever. If you're on a machine not your own (but under the custody of your parents or at school/work/library/cyber cafe or so), count on the keepers being none too pleased if you do start messing around with them at random.

If anything, remember to always click "cancel" or whatever its called, rather than "OK," to close any settings screens, even though you feel confident you didn't change anything. Just on the add chance you accidentally did

Happy gaming, now, folks.


Posted Mar 14, '14 at 8:53am



1,369 posts

... Ah, so I'm (finally) migrating to Linux Mint, Cinnamon edition.

Looks like the Unity Web Player isn't designed for it, although from the looks of it some Unity games may be.

Oh, well. I never said I was very bent on it, but, FYI as usual.

Reply to About this downloadable Player needed to play some games..

You must be logged in to post a reply!