ForumsSupport Forumwhite screen

5 2013
Theguywhodigs
offline
Theguywhodigs
3 posts
350

I've been getting a white screen for a very long time now on any and every single game I try and play on armorgames. My flash is up to date and I believe that's all I need. My old PC runs every game on here perfectly but why not my new one?

  • 5 Replies
UnleashedUponMankind
online
UnleashedUponMankind
11,177 posts
20,870

Did you have something running that block ads? If so diable it, adblockers are mostly responsable for this kind of problem.

Another thing that could cause problems are any kind of internet safety software (like netnanny or K9).

They are also some other security programs that may block things if you try to play from work/scool/etc,

jonathen
offline
jonathen
203 posts
3,970

Here you go:

But the white screen could happen If you have slow internet close other tabs focus the computer screen on the game screen (put the gaming screen in the middle) so the browser doesn't load extra features like social media button

Theguywhodigs
offline
Theguywhodigs
3 posts
350

@jonathen I dont get a black screen its just white like the background of this page, also my internet has fast speed.
@Unleashed I dont have ad blockers or any safety software, also im playing on my personal gaming pc at home.

I've been getting this problum for some time now and I don't really know what change I made to my pc but the only site I can play and load games fine on is kongregate

jonathen
offline
jonathen
203 posts
3,970

Hello open your browser in icnogento(most likely to be ctrl+shift+n)
try an other browser focus in the middle of the screen(the black or white screen) just look at it it happened to me long time ago and it is just gone after I tried opera browser.Link to opera browser:
[url]http://www.opera.com/download/get/?id=36999&location=360&nothanks=yes&sub=marine[/url]

HBKmade
offline
HBKmade
1 posts
1,775

im having problems with a few game, it shows up as a white screen with a black and white box in the upper left corner, how do i fix this?

Showing 1-5 of 5