ForumsNews and Feedback[Updated] Armor Games is going HTTPS

13 404
RavePenguin
offline
RavePenguin
471 posts
Shepherd

Hey all,

The team has been hard at work with getting the site ready for HTTPS. We are doing a gradual rollout of the work as you may or may not have already seen.

These are some of the pages that have HTTPS enabled at this first stage of updates.

  • ArmorGames.com
  • The Forge
  • Player Rankings

If you are on one of these pages and see that you have a grey lock with a red slash instead of a green lock (at the top of your browser by the URL) or some other notice of the page not being secure, please reply with some information for us. What is the site address? What browser and version of the browser are you using? Any additional information that you would like to report.

Thanks again!

-RP

  • 13 Replies
HahiHa
online
HahiHa
7,711 posts
Grand Duke

@RavePenguin

The Forge and Player Rankings both show the green lock. However, the main page doesn't. Whether I click on the AG logo on the top left to access the main page, or actually type in https://armorgames.com, I invariably end up at the address 'armorgames.com' which has the grey lock and red slash.

I am using Firefox 55.0.3 (32-bit). (Which is weird now that I think of it, considering I have a 64-bit OS. Is that normal? )

I really appreciate the transition to https. It's a good thing.

Doombreed
online
Doombreed
6,795 posts
Justiciar

Same as HahiHa. I appreciate the transition as well. the main page is not https though. I am using Chrome, 64-bit, specifically: 61.0.3163.100 (Official Build) (64-bit)

I've got 64-bit OS, Windows 7 Ultimate

RavePenguin
offline
RavePenguin
471 posts
Shepherd

Hello,

I'll pass this information along, thank you both!

HahiHa
online
HahiHa
7,711 posts
Grand Duke

The main page now also has the green lock for me.

Doombreed
online
Doombreed
6,795 posts
Justiciar

Same for me

RavePenguin
offline
RavePenguin
471 posts
Shepherd

Howdy!

We're doing another batch of HTTPS rollouts and this time we are focused on the game pages. Many of the games will be loaded under the HTTPS, but some of the games that we tested (mostly the older ones) still require HTTP due to technical limitations to keep the games working. We have done our best to make sure to catch all of these games, but we are human and we may have missed a few out of the thousands of games on our site.

If you run into any issues with the game pages in the next few days, please check out the common solutions for games not loading page first. If you still have problems, please reply to this forum thread instead of flagging the game as mentioned in the help page I linked.

Please try and include as much of the following as you can,

  • What Operating System do you have installed
  • Which browser/browser version are you using to access the game
  • The URL of the game page that is having problems
  • What version of Flash Player do you have installed
  • Quick recap of what isn't working as expected.

___________________________________________
I'll update my post with the most common questions and details as they are shared.

How do I know if my game is loading in HTTP or HTTPS?

If you do not see the HTTPS preceding the web page, the game is loading up in HTTP.

My game was working just fine before, but now my Flash Player isn't working or is giving me an error!

If you had whitelisted or allowed the Flash Player to allow all games on our site before, the player isn't aware that these allowed permissions should also be granted to the HTTPS pages. You can take the same steps as you did before to allow your browser to display the games once more.

-RP

wistress
offline
wistress
262 posts
Shepherd

Cannot play the game I play everyday (Gemcraft Chasing Shadows). It states that I have to log onto https://armorgames.com/play/15760/gemcraft-chasing-shadows, the URL I am already on. Regardless, I clicked on the link and it comes back to the same page? I am using Chrome and FP is updated automatically. As you can see, the above URL is HTTPS. Thank you!

dlbear
offline
dlbear
1 posts
Farmer

Yeah, you broke it. I'm having the same problem as 'wistress', the only difference is I use FF instead. Worked well in the AM, broke in the PM.

wistress
offline
wistress
262 posts
Shepherd

Thank you for the fix!

RavePenguin
offline
RavePenguin
471 posts
Shepherd

Hello everyone!

We wanted to extend a big thank you for your understanding while we continue to troubleshoot some of the more recent reports. The replies to this thread, your support tickets and the use of Flagging for the games have been a great help with identifying some of the unforeseen issues and settings with the games and our rollout of HTTPS across the site!

We'll continue to be on the lookout for any new reports that come in and get this looked into ASAP!

-RP

AristosM
offline
AristosM
6 posts
Shepherd

This page gets a "Not Secure" message:
http://armorgames.com/community/thread/12642209/updated-armor-games-is-going-https
Literally, this page. :-)
(But after I post, now it is secure. Weird.)

hoelmoke
offline
hoelmoke
2 posts
Peasant

I am getting the same "not Secure" as well

RavePenguin
offline
RavePenguin
471 posts
Shepherd

Hey @hoelmoke and @AristosM,

Thanks for the feedback. We are still rolling this out across the site a little at a time. For now, the forums are still under HTTP, so you may still see the not secured notifications from the browser.

-RP

Showing 1-13 of 13