ForumsSupport ForumHelp!

12 2626
turkishmaniaca
offline
turkishmaniaca
261 posts
450

Everyone. When I try to rate a game it sends me back to the home page. Why? It won't let me rate games!

  • 12 Replies
crazynaitor
offline
crazynaitor
2,959 posts
0

Well thats a glitch if you go back it might work then that happens to me sometimes its just if you rate games without playing them then it would happen.

crazynaitor
offline
crazynaitor
2,959 posts
0

Oh that is just a glitch on your computer then.

nick_coolhaha
offline
nick_coolhaha
1,333 posts
7,050

No, it's not a glicth, this usually just happens when you haven't let the game load yet, so just wait a couple seconds and then rate it.

turkishmaniaca
offline
turkishmaniaca
261 posts
450

No. I was playing UFO racing and i rated it afterward and it sent me to the home page. Then i went back and it did the same thing -.-

turkishmaniaca
offline
turkishmaniaca
261 posts
450

Dude, I was adding thing thing 4 to my faves and it took me to the home page. This is getting ridiculous. I can't flag or vote up comments anymore either. wat the ????

nick_coolhaha
offline
nick_coolhaha
1,333 posts
7,050

Have you tryed just letting it load completely? Just let it go all the way to the main menu or even begin playing it a bit, and then do whatever you want.

turkishmaniaca
offline
turkishmaniaca
261 posts
450

Ok. I played thing thing 4 for like 3 levels then clicked on rate game and it sent me to main menu. Same thing happens to the favorites.

nick_coolhaha
offline
nick_coolhaha
1,333 posts
7,050

Wow, I guess it's just not working for you right now. I say just be patience, go do something else for a while, and try it latter. Hopefully it'll work latter.

crazynaitor
offline
crazynaitor
2,959 posts
0

Yea I agree with Nick just leave it for now.

turkishmaniaca
offline
turkishmaniaca
261 posts
450

Yeah i guess -.-...sux i cant rate and add games though

turkishmaniaca
offline
turkishmaniaca
261 posts
450

Also, The game quick jump thing doesnt work either...-.-

XCoheedX
offline
XCoheedX
1,061 posts
4,575

That has happened to me too. I think the site is just going through something because it was taking forever to load something.

Showing 1-12 of 12