ForumsSupport ForumCan't Play Games

33 2517
EtherealBleu
offline
EtherealBleu
4 posts
420

I don't know what exactly is wrong. I'm using Firefox, the latest version. All of my plugins are up to date. Last night I was playing the games just fine...I remember trying out "Lucky Tower" or "Lucky Door" or something like that for the first time. I feel that I should also mention I also had erased all my cookies and cache with CCleaner, but that shouldn't affect my ability to play games, right?

Can anyone figure out what's going on?

  • 33 Replies
EtherealBleu
offline
EtherealBleu
4 posts
420

Also, I do have Javascript enabled. And I can play flash games on other sites like Kongregate and flasharcade fine too. The same thing happens on Chrome.

dogpoo
offline
dogpoo
6 posts
115

Looks like it's a problem with their new pre game ads, I have the same issue too.

DontFeedTheTroll
offline
DontFeedTheTroll
2 posts
1,315

I'm experiencing the same problem.. Not sure how to fix it.

EldritchBlueRose
offline
EldritchBlueRose
3 posts
3,755

I have the same issue as well.

Just curious, what OS are you guys running? I'm running Mac OS X 10.5.8

DontFeedTheTroll
offline
DontFeedTheTroll
2 posts
1,315

I'm running the same as you Edlritch

Mickeyryn
offline
Mickeyryn
278 posts
1,870

I had that problem once. I think the best thing to do is check again if your plug-ins are up to date, but obviously you have done that already. Are you using a Mac? And if so, is it a refurbished one? I had one of those, Apple stopped doing updates to it, and it pretty much quit working. I had to throw it out :/

That might be your problem.

Mickeyryn

dogpoo
offline
dogpoo
6 posts
115

On a mac here too... just tried on my PC and that works fine. So maybe that's the issue?

Mickeyryn
offline
Mickeyryn
278 posts
1,870

Yeah, man. It is probably, sadly, the ol' Mac.

And again, how old is it, and is it refurbished?

Mickeyryn

Wizzyfizzy
offline
Wizzyfizzy
2 posts
2,160

I think its the pre-game ads, Never had a problem until they came

Ferret
offline
Ferret
9,281 posts
6,150

Greetings! We've located the error, and we're working on a solution. Sorry about that. Could you try a different browser, and see if it persists?

EldritchBlueRose
offline
EldritchBlueRose
3 posts
3,755

I tried it both on Firefox and Safari and the games still do not run.

matt785
offline
matt785
88 posts
1,930

I cant play any of the games !!! The pre-game ads either don't load or they play, end, and the box that the game should appear in stays black!!!! I don't want to watch ads; I want to play games!! This has been going on for 2 days now; I will have to stop using this site for other ones if it continues..... like anyone cares..

I have nothing against the ads, but since their messing up the games I think Armorgames should find a different way to get capital.

Ferret
offline
Ferret
9,281 posts
6,150

Thanks for the info Matt, we're trying hard to fix it.

KCOLI
offline
KCOLI
1 posts
1,510

was frustrated but now that i know your working on it is good enuff for me. ThANKS.

EtherealBleu
offline
EtherealBleu
4 posts
420

Thanks for replying, Ferret. Hopefully you'll find a solution for us soon...for the other people who were asking about my OS, I'm running a Windows 7 64-bit system. So I don't think it's isolated just to macs.

Showing 1-15 of 33